Barry Kauler poinformował o wydaniu Precise Puppy 5.4

Barry Kauler ogłosił wydanie systemu Precise Puppy 5.4. Jest to nowa gałąź rozwojowa Puppiego, system bazuje na dystrybucji Ubuntu Precise 12.04.1 i zachowuje z nim kompatybilność binarną co sprawia że oprócz pakietów pet dla Puppiego Precise możemy również instalować pakiety deb dla Ubuntu12.04.1. Decyzja o rozkręceniu osobnej gałęzi rozwojowej podyktowana jest faktem istnienia olbrzymiej ilości dostępnych pakietów deb.

Mimo że jest to pierwsze wydanie Precise, zdecydowano nadać mu numer 5.4 aby wskazać jego pozycję w stosunku do Warego5.3 i Slackiego5.3.3. Prace nad nowym systemem trwały dość długo bo od kwietnia 2012, czyli od momentu wydania Waregto5.3. Szczególne znaczenie miały zmiany na poziomie Woof oraz przekonstruowanie Menedżera Pakietów. Ta ostatnie rzecz wprowadza pewną nowość, mianowicie pakiety zostały podzielone na 5 kategorii, więc musimy wiedzieć co gdzie znaleźć, na przykład pakiet spolszczeniowy (langpack_pl) znajdziemy w kategorii noarch w zakładce setup. System spolszczony jest w około 80%, menu i podpisy pod ikonami na pulpicie po polsku, w poszczególnych aplikacjach obok w większości polskich opisów znajdują się pojedyncze obce wtrącenia.

Gwoździem programu jest moim zdaniem fakt że twórca systemu zwraca uwagę że ponieważ Ubuntu12.04.1 będzie wspierany przez 5 lat więc można się tego samego spodziewać po Puppim Precise. Skoro tak się stanie, będziemy mieć pierwszy przypadek Puppiego z długoterminowym wsparciem.

Mimo najdłuższego chyba w historii Puppiego okresu testowego system najwyraźniej nie jest wolny od chorób dziecięcych. Pierwsze co mnie zaskoczyło to niemożność zainstalowania Gruba. Kombinowałem na wszystkie sposoby a i tak musiałem bootloader wrzucić przy pomocy Slacko. Następną niespodziankę zgotowała mi konsolowa aplikacja do obsługi modemu: nie mogłem się mianowicie rozłączyć z netem, skrót klawiaturowy do przerwania połączenia nie działał. Myślę że jak to zwykle bywa około wersji 5.4.2 system stanie się stabilny.
Puppy Precise pracuje pod kontrolą jądra 3.2.29, gotowe do pobrania iso ważące 158 megabajtów możemy pobrać stąd.

One thought on “Barry Kauler poinformował o wydaniu Precise Puppy 5.4

  1. instalowałem na kilku komputerach. w przypadku posiadania już gruba, grub 2 automatycznie dopisuje stosowną linijkę (na dysku miałem xp i xubu). nie wiem jednak dlaczego jako unknown. próbowałem zedytować, ale wówczas znów dodawał linijkę z unknown linuxem.
    w momencie, kiedy nie miałem gruba (instalowałem obok xpeka) mogłem grub (pierwszy) zainstalował się grub4dosem. fatalnie wygląda, ale działa.
    zainstalowałem programy z repozytorium. chromium bezproblemowo, ale libreoffice rozsypał mi cały system. zamiast tekstów krzaczory, zamiast ikon, jakieś znaki drogowe. ale generalnie działa super i podoba mi się. do prac domowych w zupełności wystarczy. a jak zainstalować coś spoza repozytoriów? jest to możliwe? jeszcze tego nie doczytałem.
    a gdybym miał skypea, jakiegoś officea (libre, open) i np. operę, to w zasadzie nic mi (i podejrzewam 80% innych osób) więcej nie trzeba.

Dodaj komentarz

Twój adres e-mail nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

Możesz użyć następujących tagów oraz atrybutów HTML-a: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>